Apache2 ne sert pas index.php


0

Mon serveur est assez vieux (basé sur SuSE 9), et pendant que j'essaie de passer par la peine de mise à jour vers les derniers Apache2, PHP5 et MySQL, j'ai rencontré ce problème avec un de mes domaines hébergés.

Le site a un index.php, et si je navigue vers leur site example.org/index.php il affiche bien.

Mais si je navigue vers http://example.org ou http://example.org/, Firefox ouvre une boîte de dialogue me demandant si je veux enregistrer le fichier ou l'afficher dans un programme. Le fichier téléchargé est une copie du fichier index.php non traité.

Le fichier de configuration pour le domaine n'a pas changé, mais clairement j'ai foiré quelque chose. Dans le fichier de configuration est "DirectoryIndex index.php". Dans le DocumentRoot est un fichier .htaccess avec seulement "XBitHack sur".

Confondre le problème est que j'ai un autre domaine hébergé avec une installation Wordpress qui utilise également index.php, et la navigation fonctionne très bien.

Voici le site: http://www.sjbridge.org ou http://www.sjbridge.org/index.php

Mojo

Voici quelques plus d'informations: Quand je navigue à http://www.sjbridge.org, Firefox présente le fichier comme "application/x-httpd-php" dans le type de contenu , mais pour /index.php, le type de contenu est, bien sûr, text/html.

  0

Serait-ce que ça envoie les mauvais en-têtes? Que dit votre httpd.conf? 22 févr.. 092009-02-22 02:45:55

  0

Ça me va bien ... 22 févr.. 092009-02-22 02:51:08

1

Ugh, j'ai effacé le cache dans mon navigateur et le problème est parti. Laissez-moi vous dire "Ne t'inquiète pas".