Visual Studio 2005で.NET 3.0を使用するには?


3

私のGoogle-fuはこの問題で私に失敗しています。

自分のマシンにVisual Studio 2005を持っている同僚がいます。私はVisual Studio 2008を持っています。彼はC#3.0で書いたプロジェクトを開こうとしていますが、これまでのところ、varのように、3.0コードのVS2005バーフがあります。

彼は、Windows WorkflowのVisual Studio 2005 Extensionsと同様に、3.0と3.5のフレームワークがインストールされています。ほかに何が必要ですか?それとも、私は失われた原因、私の思考に拍車をかけた野生のガチョウの追撃を追求しているのですか?

VS2008またはExpressエディションをインストールすることをお勧めしないでください。これは現時点では不可能です。 :(

4

をこれまでのところ、私はそれを理解し、これを新しいC#3.0コード機能を使用していなかった場合、VS2008で作成されたプロジェクト(2.0フレームワークに対してコンパイル)で作業できるはずですが、2005年のコンパイラは


0

IDE自体は、3.0の機能をサポートしていないかもしれません。あなたは、彼がOKを実行することができるはずである2.0にコンパイルすることができます3.0の機能なしで生きることができる場合。


2

vs2005でプロジェクトファイルを再作成してから、ファイルのヘッダーをvs2005に更新して、ビジネスに復帰することができます。詳細はRick Strahls Blogをご覧ください。どのようにそのd 1。

Visual Studio 2005/2008 Interoperability

でプロジェクトコンバータを見て価値があるあなたもインストールするには、.NET 3.0のための2005個の拡張機能のVisual Studioが必要な場合があります。 WWF Extensions